Mantis Bugtracker
Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000043 [Babbletower] configuration major always 06-25-08 13:19 11-06-08 08:20
Reporter petrovski View Status public  
Assigned To xelalex
Priority normal Resolution no change required  
Status resolved   Product Version 0.9.4
Summary 0000043: I get boxes instead of Japanese characters in search result
Description I am using the wadoku dictionary from the homepage.
The search results do not display Japanese characters
but little squares. It looks like an encoding problem.
Additional Information
JRE 1.5.0_14-b03
Attached Files  fontconfig.properties [^] (12,908 bytes) 06-25-08 14:53

- Relationships

- Notes
(0000093)
xelalex
06-25-08 13:54

I suspect it is a configuration problem of your JRE, i.e. fonts may not be configured correctly for Japanese. How this is configured depends on the JRE you're using. To get started, have a look at

http://www.babbletower.net/manfont.html [^]

The information there is geared towards Java 1 runtimes and a bit outdated. Things have changed a bit in recent Sun JREs. The font config file is now lib/fontconfig.properties.
 
(0000094)
xelalex
06-25-08 14:56

Attached is a fontconfig.properties that I use on SuSE 10 with Sun Java 1.5.0_03_b07. You can place this in the lib folder of your JRE and check whether that changes anything.
 


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
29 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker