Mantis Bugtracker
Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000042 [Babbletower] usage minor always 06-25-08 13:15 06-26-08 15:47
Reporter petrovski View Status public  
Assigned To xelalex
Priority normal Resolution no change required  
Status closed   Product Version 0.9.4
Summary 0000042: OutOfMemoryError when creating index for wadoku dictionary
Description With memory parameters for the Java VM it works but when you call it like it is described you get OutOfMemoryError. Here is my script:

#!/bin/sh

dictionary='wadoku'
encoding='UTF8'
index='wadoku.idx'
depth=6

java -Xms50m -Xmx250m -classpath babbletower.jar Index $dictionary $encoding $index $depth
Additional Information
JRE 1.5.0_14-b03
Attached Files

- Relationships

- Notes
(0000092)
xelalex
06-25-08 13:40

Does this mean with option -Xmx250m it works, but without it doesn't? If so, then that is correct behavior. Depending on the size of the dictionary, the indexer may require a considerable amount of memory. For Wadoku, 250MB seems to be the minimum.
 


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
28 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker