Mantis Bugtracker
Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000020 [Babbletower] request for feature feature N/A 08-24-03 19:59 06-26-08 15:52
Reporter karen View Status public  
Assigned To xelalex
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000020: key to Jim Breen's abbreviations built into Babbletower
Description Jim Breen uses many abbreviations in edict and it is hard to remember what they all are without consulting outside sources. I would like to see a key or legend of some kind built into Babbletower to make this easier.
Additional Information I can provide a list of these abbreviations if necessary. It's several years old and I don't know if it is outdated.
JRE
Attached Files

- Relationships

- Notes
(0000006)
xelalex
08-24-03 22:08

This should not be a feature that's tailor made for a specific dictionary such as edict. I'm thinking more about something along the lines of a general legend feature, e.g. if you place a file {dictionary name}.legend in the same folder as the dictionary, Babbletower will extract the legend info from that file and offer it in the GUI.
 
(0000007)
karen
08-24-03 22:33

agreed. i hadn't even considered applying this to other dicts. i guess users would create these themselves? are there any precompiled lists out there? i would definitely want to make/use one for koujien.
 
(0000057)
xelalex
01-19-04 20:43

Hi Karen! Finally implemented this (please try TR10). You need to put a "xyz.legend" file into the directory in which the dictionary "xyz" resides, e.g. "edict.legend" for "edict". A sample file for edict is in the "latest" folder. The legend file needs to be UTF8 encoded, one expalantion per line in the format: "abbreviation{tab}explanation".

In the dictinary view, highlight an abbreviation you want to check in the legend. A popup menu should appear - "Add to wordbox/Lupe/Legend". "Add..." doesn't work yet, and "Lupe" does the obvious. The third item reads "Legend" if the highlit abbreviation could not be found in the legend, otherwise the first few words of the explanation show in the third menu item. Selecting the third item opens the legend, and if the abbreviation exists, its positioned right there. If the third item is disabled, no legend file for the current dictionary exists.

Holding the mouse button/stylus down for a moment will return to the previous screen.

Let me know if this works ok.
 
(0000058)
karen
01-25-04 18:45

Very nice! I like the way you've implemented this. It will work well with the dictionary I'm compiling, assuming I get it into a compatible format.

The menu is hard to activate on Zaurus, but I believe that is because of jeode or Qt. Hilighting with the pen is twitchy and if I manage to highlight just the abbreviation (or character, for lupe), usually the menu isn't activated. Over several tries, the menu was activated only once. I managed to figure this out at one point, but now I've forgotten what the secret is. I'll keep looking.

No problems on the mac. Works just as it is supposed to. This will really come in handy in the future, thanks!
 
(0000060)
xelalex
02-12-04 11:18

This feature is now fully impelemented. From now on, everything is accessible only via the popu menu, i.e. lupe, add to wordbox, and legend.

Now you can also reference a legend. For example, most of the Monash lot dictionaries use the same abbreviations as "edict". To make the legend available for all of these dictionaries, you could duplicate and rename the "edict.legend" file for all of them, but that's of course inefficient. Instead, you can specify a dictionary from which you want to use the legend, in the ".dictionary" setup file. E.g. to use the "edict" legend for "ediclsd4", add the line "legend = edict" to "ediclsd4.dictionary".

If all works, I will finally release version 0.9.2, so let me know of any problems with this new feature.
 
(0000061)
xelalex
02-12-04 11:19

Forgot to mention, latest version is TR11. If you have some time, check it out.
 
(0000062)
karen
03-19-04 05:59
edited on: 03-19-04 06:03

Did you change something in TR11? I can't get the popup menu to reliably display the part of speech information. When I first started BT, the menu was working properly, but longer explanations, like noun, were being cut off. This was on both mac and zaurus. Now the zaurus popup works fine, but on the mac, the bottom two items, lupe and legend, are gray regardless of what is selected and no part of speech is displayed. Between the menu working and not working, I hadn't touched anything. It wasn't fixed after I quit and restarted BT. Even when I could manage to get lupe and legend available, there was still no part of speech. I couldn't reproduce this on the zaurus, but in its menu there are two each of lupe and legend. One set is at the top of the menu and doesn't do anything when selected. The other set is at the bottom and call lupe or legend depending on which is selected.

edited on: 03-19-04 06:03
 
(0000063)
xelalex
03-24-04 11:26

Cutting off longer explanations is deliberate, to prevent the menu from getting too wide.

> Now the zaurus popup works fine, but on the mac, the bottom two items, lupe and legend, are gray regardless of what is selected and no part of speech is displayed.

Does the highlighting of the selected text disappear when you open the popup menu? Both menu options are disabled if no text is highlit. Do you see the same problem when you open the menu via the Mac's context menu open (equivalent of right click on Windows), not via press button and wait?

> I couldn't reproduce this on the zaurus, but in its menu there are two each of lupe and legend. One set is at the top of the menu and doesn't do anything when selected. The other set is at the bottom and call lupe or legend depending on which is selected.

_Very_ strange indeed. Can you provide a screenshot?

Could you reproduce all problems with release 0.9.2?
 
(0000076)
xelalex
11-07-04 16:04

implemented in 0.9.2
 


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker