Mantis Bugtracker
Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000016 [Babbletower] incompatibility major always 08-23-03 20:36 06-26-08 15:52
Reporter karen View Status public  
Assigned To xelalex
Priority normal Resolution fixed  
Status closed   Product Version 0.9.1
Summary 0000016: BT hangs when bringing up scheduled grading menu while quizzing
Description when quizzing with scheduled quiz management, BT hangs after pressing enter to bring up the grading menu window. Console says "unable to get graphics context".
Additional Information
JRE
Attached Files

- Relationships

- Notes
(0000001)
karen
08-23-03 20:37

forgot to set severity to "issue"
 
(0000009)
xelalex
08-25-03 08:13

Do you get a stack trace on the console when that happens? If so, could you attach it here?
 
(0000011)
karen
08-27-03 07:29

no output in console to attach...
 
(0000014)
xelalex
09-05-03 21:04

I had a look at this. BT doesn't call getGraphics() in any of the code involved here, at least not directly. Smells a bit like yet another bug in Jeode's AWT implementation. I added a few debug print outs to find out where exactly this hangs up. Karen, could you reproduce this situation with test release 2 and send me the print out on console that you get?
 
(0000015)
karen
09-06-03 20:59

ok, tried again. I changed ROM's to the kompany.rom, which won't really have any effect since it is based on the sharp rom and also comes with jeode. the first time I tried grading a quiz, the scheduled management box appeared, but didn't respond to pressing the hardware buttons or tapping. when I tried to bring it up again to grade the next card, it didn't appear. since then, the behaviour has been the same: I hit enter to bring up the box, and the focus goes away from the main BT window, but no grading window appears. I can get focus back by ending the quiz. The console says:

Making dialog...
Selecting item...
Setting visible item...
Placing dialog...
Showing dialog...

but I don't see it if it is there.

Starting BT with several apps open slowed it down enough for me to see that sometimes the grading window is being drawn and disappearing immediately. When this happens, I get the focus back in the main window. If I don't see the window flash, I have to end the quiz to get control back.

Don't know why, but sometimes the grading window does appear after ending a quiz and restarting it, but it doesn't respond to the hardware keys or pen tapping and sometimes it isn't drawn completely. it won't go away without killing BT.

Here is a screenshot of the partial grading window:

http://tokimi.collapsar.net/tmp/grading_window_partially_drawn.jpg [^]
 
(0000016)
xelalex
09-06-03 22:09

OK, that may have been a good hint. I did a slight modification to the dialogs, that BT is using. Could you try TR3? With some luck it's fixed now.
 
(0000017)
karen
09-06-03 23:41

Still no go. behaviour is a little different with this console output:

Making dialog...
Selecting item...
Setting visible item...
Placing dialog...
Showing dialog...

Here's what's different: start quiz; hit enter; hit enter again; grading box flashes and next card is brought up; hit enter, enter; nothing happens; hit enter again; grading box starts to draw and BT freezes. Alternately, the enter-enter-nothing happens-enter-partial draw-freezing sequence occurs on the first flash card.

These events consistently occur now, whereas before there was more variation.
 
(0000018)
xelalex
09-07-03 12:08

That's bad news. I had a look at this list of Jeode bugs:

http://www.alterna.tv/jeodebugs/ [^]

Bug 32 seems to be of interest here. I'll give this some more thought, but feel that the consequences of this Jeode bug are that dialogs simply can't be used here, so I would have to completely rewrite the grading stuff, in a way that doesn't use dialogs. Not sure whether I really want to do that. Also, do other dialogs in BT work correctly? E.g. file and import/export dialogs, save wordbox on exit?
 
(0000019)
karen
09-07-03 19:57

yes, they usually work fine. occasionally the open/save dialogs appear super small (around 8x8 pixels) or look squashed, but these issues are never persistent and don't occur often. I don't have any problems using BT and these dialogs. Here is a screenshot of a squashed dialog:

http://tokimi.collapsar.net/tmp/squashed_dialog.jpg [^]

Actually, the bug keeping me from making flash cards on my mac is much more urgent to me than scheduled quiz management.

Speaking of mac, testing scheduled quiz management reveals that the grading dialog is only presented after every other flash card. if I just hit enter every time (start quiz; hit enter to reveal card; hit enter to bring up dialog; hit enter to grade; repeat) then the dialog appears every time. if I grade using the up and down arrow keys for the other options in the dialog, the dialog doesn't appear again until the next next flash card. grading using grades 1 and 5 work ok. ok on zaurus, too.
 
(0000020)
karen
09-07-03 20:08

mac console says:

Setting visible item...
Placing dialog...
Showing dialog...

whether it draws the grading dialog or not. says "Selecting item..." if I select a dialog item.
 
(0000021)
karen
09-07-03 20:13

also grading dialog on mac isn't wide enough. i can only see the words "correct, recall" in the first two items. screenshot:

http://tokimi.collapsar.net/tmp/small_grading_window_mac.jpg [^]
 
(0000022)
xelalex
09-07-03 21:56

For the grading dialog problem on Mac, think I got it. It's probably the list events misbehaving again. We saw that already in the shelf setup dialog, i.e. programmatic selection of list items fires event, which is not in accordance with Java API spec. Please check TR4, it's hopefully fixed there.
 
(0000023)
karen
09-07-03 23:23

seems to be fixed on the mac. It worked correctly every time I graded a card. also reflected in console output:

Selecting item...
Setting visible item...
Placing dialog...
Showing dialog...
grade: 2

the grade level wasn't in the console output before.
 
(0000026)
xelalex
09-09-03 15:54

OK, so this one is resolved for Mac. Now, for Jeode, I don't think there's a solution using a dialog for grading, due to above mentioned Jeode bug. What I could do is to activate keys '1' through '5' for grading, i.e. you press the grade key directly instead of using a dialog. The SL-5x00 have keyboards, so maybe that would make for an acceptable workaround? I think in general it would be good to add that for all platforms with keyboards.
 
(0000027)
xelalex
09-12-03 23:40

OK, I activated keys 1 through 5 for grading (including number pad). You can check with TR5. Karen, let me know whether this solution is OK with you. If so, I'll close this bug as resolved.
 
(0000030)
karen
09-13-03 01:18

It works! Both using keys 1-5 and the grading dialog work! I was able to successfully grade a quiz using both the hardware keyboard and the cursor keys! Great job, Alex!

However, I would suggest making the hardware grading keys user configurable, since on the zaurus, you have to press function+letter to input numbers. Or did you mean the PIM shortcut keys on the keyboard cover? Still, I think we can call this one resolved. Thanks!
 
(0000031)
xelalex
09-13-03 22:53

Does that mean the grade dialog now works on both Mac & Zaurus? I noticed today that something I did broke the grade dialog on my Cassiopeia, but that was easy to repair. To double check that everything still works on your platforms, can you try TR6? If it still works, I'll close this bug. Also, note that in TR5 the grade is determined correctly, but a wrong one is send to the wordbox (always best grade ;-) My mistake, shouldn't have done that last night while being so tired. So DON'T DO ACTUAL QUIZZES WITH TR5!!! This is fixed in TR6. I also activated the QWERT keys for grading (same function as 12345). You're right that keys should be user definable. I thought about it before, but I want to make that a general mechanism, i.e. for all places in BT where keys are used. It'll have to wait a little though. Will put it in the database as a request for feature.
 
(0000033)
karen
09-21-03 22:15

the grading dialogs in TR6 seem to work fine on both mac and zaurus. I don't know about zaurus, but they were, in fact, broken on mac in TR5. Looks like you can close this one.
 


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker