Mantis Bugtracker
Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000014 [Babbletower] incompatibility major always 08-23-03 20:08 06-26-08 15:52
Reporter karen View Status public  
Assigned To xelalex
Priority normal Resolution fixed  
Status closed   Product Version 0.9.1
Summary 0000014: wordbox popup menu broken on mac in this release
Description Holding down mouse button brings up popup but no options are avaiable without first moving mouse pointer over "file" and "new". selecting new brings up second popup with "paste" sometimes available but submenu items are never available, making it impossible to create new flash cards, lists, or folders. Mousing over paste in either popup doesn't make it available like file and new in first popup.
Additional Information I think that this was not a problem in previous builds, but I would need to test to be sure. Menus function proplerly under jeode.
JRE
Attached Files

- Relationships

- Notes
(0000013)
karen
08-30-03 19:25

also broken in version of 0.9.1 available for public download.
 
(0000024)
xelalex
09-08-03 15:08

Quick question: do you release the mouse button on the Mac after you brought up the popup menu, or do you have to keep it pressed?
 
(0000025)
karen
09-09-03 02:20

I can hold the mouse button or release it after the main popup menu appears, but the behaviour is the same. I have to mouse over the second popup before the paste submenu becomes available, but no submenu item is available; they're all disabled.
 
(0000028)
xelalex
09-12-03 23:48
edited on: 09-12-03 23:48

I think I know where this behavior comes from, but can't fix it since that would break another work-around for incompatible AWT list behavior on the PocketCosmo :-( As a workaround, I made this popup menu "a real one", i.e. you can now also activate it directly via the proper popup invoking mechanism of your platform. On Windows right click the list, on Mac - what was it? Ctrl + click? If your platform doesn't have any such mechanism, as many PDAs do, then use the hold-dow-pen-and-wait method as before. Karen, let me know how this works for you. (See TR5)

edited on: 09-12-03 23:48
 
(0000029)
karen
09-13-03 01:01

still no good. the second popup still isn't working. It won't give me "into", "before" and "after" after I make a new folder, list or item, no matter what I do. I haven't managed to find a way to force or trick it into making a new item. If I click anywhere in the submenu, the menu just goes away and no item is created. There's no console debug output to attach, so I'm afraid I can't be more helpful here. It might be simpler and quicker to just make the word box in a text editor and then bring it into BT. I just need to examine the file format in a text editor.

I also can't add items to downloaded wordboxes on the mac. Same situation, no paste submenu items available after making a new object. After performing the same sequence (select new->*[list, in this case]->paste), I actually was able to add a new list to one of the kanjismpt wordboxes, but was never able to reproduce it.

Here is what I'm getting when I can't paste:

http://tokimi.collapsar.net/tmp/no_paste_mac.jpg [^]
 
(0000032)
xelalex
09-13-03 23:00

I must admit that I'm a bit confused here. Let's define a test sequence:
1) Start with a fresh wordbox
2) Bring up the popup menu, open the "new" submenu, and select "list"
3) The main popup menu should come up again with now only the "paste" submenu being enabled. The console should also say "creating new item ..."
4) In the "paste" submenu, "before" and "after" should be available. Either one should put a new list into the empty wordbox.
5) After pasting, a text input field for entering a list name should come up.

What happens when you do this? Do you get the console out about creating a new item? The popup I see in your screen shot seems to be the first one, i.e. the one you open in step 1). That's strange.
 
(0000034)
karen
09-21-03 22:20

That is exactly what I'm doing except step 4 doesn't happen. The popup I get is the one you saw in the screenshot. The console says "creating new item", but nothing happens after step 3.
 
(0000036)
xelalex
09-23-03 20:10

OK, I have a suspicion, but need some more info to "make the arrest". I put more debug output into the code involved (TR7). Could you run the test sequnece and attach the console out here?
 
(0000038)
karen
09-27-03 19:28

Here's the console output from tr7:

# Opening popup:
# file menu: true
# ix: -1
# ix OK: false
# paste sub-menu: true
# paste before: true
# paste after: true
# paste into: false
# paste into mi: false
# paste menu: true
# new menu: true

--this is when I hold down the mouse button before selecting an item from the 'new' submenu

#
# Creating new item: nl
# New item: dictionary.a.j@557a77
#
# Opening popup:
# file menu: false
# ix: -1
# ix OK: false
# paste sub-menu: true
# paste before: true
# paste after: true
# paste into: false
# paste into mi: false
# paste menu: true
# new menu: false

--and this is when it's waiting for me to select an item in the 'paste' submenu, but the items aren't availble.
 
(0000040)
xelalex
10-16-03 22:05

Ok, my suspicion is that while the event from the first popup menu is handled, that menu is still visible. Now during event handling, the popup menu is re-opened with appripriately enabled/disabled menu items. Since the menu is still on screen, this may not have any effect. I put a delay before the re-opening and let a different thread do it. A bit of a hack, but hope that fixes the problem on Mac. Could you try the test sequence with TR8?
 
(0000046)
karen
10-22-03 00:26

Here is the cosole ouput from tr8:

# Opening popup:
# file menu: true
# ix: -1
# ix OK: false
# paste sub-menu: false
# paste before: false
# paste after: false
# paste into: false
# paste into mi: false
# paste menu: false
# new menu: true
#
# Creating new item: nf
# New item: dictionary.a.i@d38976
#
# Opening popup:
# file menu: false
# ix: -1
# ix OK: false
# paste sub-menu: true
# paste before: true
# paste after: true
# paste into: false
# paste into mi: false
# paste menu: true
# new menu: false

but even though the paste menu is available in the second popup, none of the submenu items are; before, after and into are all gray.
 
(0000047)
xelalex
10-27-03 21:10

Another try. Please check TR9. If this doesn't work, we may be ready for a bug report to SUN/Apple...
 
(0000048)
karen
10-27-03 23:55

Well done. I was able to create new folders, lists, and entries. It was a bit quirky at times, meaning new items didn't always appear when I clicked "before" or "after", but it is usable now. When I had the quirky issues, I created a new file and started over and everything worked as it should have. Pasting search results into vocab lists and creation of new entries via arrow shortcut button also works. Thanks Alex!
 
(0000049)
xelalex
10-28-03 08:08

Now isn't that amazing ;-) The problem was this: the order of enabling/disabling the paste submenu and its items was items first, then the submenu itself. Now it seems that on the Mac, enabling menu items while the menu they belong to is disabled is not reflected by their peers on screen, although the actual AWT MenuItem objects do reflect the change correctly! I reversed the order, i.e. submenu is enabled first, then its menu items, and voila.

Now before resolving this, I'll roll back some of the changes I made, notably the delay before the second popup appears, and opening this second popup from a different thread. Since that wasn't the cause of the problem, I would like to get rid of it. I'll post another note to this bug when TR10 is ready.
 
(0000050)
xelalex
10-28-03 20:02

I uploaded TR10. The delay between showing the popup nebus is removed and it is opend from within the AWT event queue thread, as it used to be. Could you check wether this still works?
 
(0000051)
karen
10-29-03 02:52

After creating the new item, I have to dismiss the automatic popup and manually bring up the popup before the paste menu is available, even though the debug information says "true" for the paste submenu. After I do this, the new item added into the specified place. In other words,

# Creating new item: ne
# New item: new
#
# Opening popup:
# [m] file menu: false
# [i] ix: 0
# [b] ix OK: true
# [b] paste before/after: false
# [b] paste into: true
# [m] paste menu: true
# [mi] paste before: false
# [mi] paste after: false
# [mi] paste into: true
# [m] new menu: false

submenu is gray after this one, but...

#
# Opening popup:
# [m] file menu: true
# [i] ix: 0
# [b] ix OK: true
# [b] paste before/after: false
# [b] paste into: true
# [m] paste menu: true
# [mi] paste before: false
# [mi] paste after: false
# [mi] paste into: true
# [m] new menu: true

available after this one.
 
(0000052)
xelalex
10-29-03 08:09

OK. So I wasn't wrong about putting in a delay, after. So there definitely is a lot wrong with menus on Mac/Java. The "true" in line

 # [m] paste menu: true

is obtained by calling isEnabled() on the paste sub-menu, meaning that it is enabled, but is not shown as such on screen. I would consider wrapping up a bug report for SUN/Apple, but I don't think I have the time right now.

Anyway, we roll back to TR9, which already fixed the bug, and discard TR10.
 


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker